Setting VPN L2tp Server di VPS Mikrotik CHR (X86_64)

YOUSHE.ID - Halo sobat youshe pada kesempatan kali ini saya akan membahas mengenai cara setting VPN L2tp Server di vps mikrotik chr. Jadi begini maksudnya, saya akan jadikan vps mikrotik chr ini sebagai server pusat vpn dengan metode l2tp. Sebenarnya ada banyak sich selain lt2p server seperti PPTP Server, SSTP Server dan OVPN Server. Namun bahasan kali ini hanya saya fokuskan ke L2TP server aja terlebih dahulu.

Langkah pertama dalam pembuatan vpn server l2tp di vps mikrotik chr x86- x64 ini yang perlu kita lakukan adalah mengaktifkan l2tp server terlebih dahulu dengan cara memberi centang pada pilihan enable. Urutannya masuk menu PPP terus pada tab Interface pilih L2TP Server nanti akan muncul jendela baru dan centang bagian enable lalu apply OK.
Setting VPN L2tp Server di VPS Mikrotik CHR
Oh iya dibagian Use IPsec jika pengen kita aktifkan tinggal pilih yes lalu untuk IPsec Secret bisa di isi bebas misal VPN. Itu baru tahap awal dari setting mikrotik chr di vps sebagai serve l2tp. langkah selanjut kita akan membuat user l2tp.

Membuat User L2TP
Cara membuat user l2tp sangat mudah cukup masuk ke menu PPP > Scret > + lalu isi input name, ppasword, local address, remote address , apply dan OK
Name : tulis username bebas sesuka hatimu
Password : disini tempat untuk password nya
Local Address : Isi Bebas yang penting beda dengan remote addresscontoh: 10.10.10.38
Remote Address : Isi bebas dan jangan di samakan dengan local address contoh: 10.10.10.39
Lalu Apply dan Ok

Cara membuat user l2tp
Nah untuk tahapan setting VPN L2tp Server di VPS Mikrotik CHR (X86_64) di bagian server sudah selesai tinggal Setting VPN L2TP Client. Nah untk di bagian client settingan tergantung kebuthan kita, misal mau buat ngeremote router mikrotik juga bisa.

Baik sekarang akan saya berikan contoh script untk vpn remote baik disisi server maupun client:
Di Server VPN:
/ppp secret
add local-address=21.10.87.2 name=contohuser password=@password123 profile=default-encryption remote-address=87.10.21.2
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=8702 protocol=tcp to-addresses=87.10.21.2 to-ports=8702

Di Bagian Client:
/interface l2tp-client
add connect-to=IPPUBLIK disabled=no name=l2tp2 password=@password123 user=contohuser
/ip firewall nat
add action=dst-nat chain=dstnat dst-address=87.10.21.2 dst-port=8702 protocol=tcp to-addresses=IP-LOCAL-ROUTER to-ports=80
OK untk tutorial tentan pembuatan vpn l2tp server di vps saya rasa sudah selesai. Cukup sekian terima kasih
© YOUSHE. All rights reserved. YOUSHE V1.0