PTP Mikrotik Script Generator

last updated date

PTP Script Generator For Mikrotik Routeros

Update Script

Download Script Mikrotik Router 1
Generate : interface bridge, interface wireless, interface list, interface wireless security-profiles, interface bridge port, interface list member, ip address and system identity
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n country=no_country_set \
disabled=no frequency=5745 frequency-mode=superchannel installation=any \
mode=bridge ssid=YOUSHE
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk mode=dynamic-keys \
supplicant-identity=MikroTik wpa-pre-shared-key=PASS*** \
wpa2-pre-shared-key=PASS***
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/interface list member
add interface=ether1 list=WAN
add interface=wlan1 list=LAN
/ip address
add address=192.168.1.253/24 interface=wlan1 network=192.168.1.0
/system identity
set name="MIKROTIK 1"
Download Script Mikrotik Router 2
Generate: interface bridge, interface list, interface wireless security-profiles, interface wireless, interface wireless nstreme, interface bridge port, interface list member, ip address, ip dns, ip firewall nat, ip route, system identity
/interface bridge
add name=bridge1
/interface list
add name=WAN
add name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
add authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys \
name=profile1 supplicant-identity="" wpa-pre-shared-key=PASS*** \
wpa2-pre-shared-key=PASS***
/interface wireless
set [ find default-name=wlan1 ] band=5ghz-a/n country=no_country_set \
disabled=no frequency=5745 frequency-mode=superchannel installation=any \
mode=station-bridge security-profile=profile1 ssid=YOUSHE tx-power=24 \
tx-power-mode=all-rates-fixed
/interface wireless nstreme
set wlan1 enable-nstreme=yes
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/interface list member
add interface=wlan1 list=WAN
add interface=ether1 list=LAN
/ip address
add address=192.168.1.254/24 interface=ether1 network=192.168.1.0
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge1
/ip route
add distance=1 gateway=192.168.1.1
/system identity
set name="MIKROTIK 2"






© youshe.id
© YOUSHE. All rights reserved. YOUSHE V1.0